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Tema 3:
El entorno de diseño
Xilinx ISE Design Suite

Diseño automático de sistemas
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 Xilinx ISE Design Suite
 Flujo de diseño y validación. 
 Volcado de bitstreams. 
 Síntesis y prototipado.
 Validación por simulación.
 Organización de proyectos.
 Controlando XIlinx ISE.
 Ligaduras de diseño.
 Ligaduras de implementación.
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 Conjunto de herramientas para la síntesis lógica y física de sistemas 
digitales sobre FPGAS/CPLDs integradas en un interfaz gráfico común:
o Gestión integral del proyecto.
o Edición del código fuente.
o Síntesis.
o Validación por simulación.
o Llamada a otras herramientas auxiliares
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 herramientas EDA

 Esta formado por las herramientas:
o Project Navigator: Interfaz gráfico común de las herramientas EDA de Xilinx.

• Incluye la gestión de proyectos y los algoritmos de síntesis e implementación.

o Plan Ahead: Interfaz gráfico alternativo al Project Navigator.
o iSIM Simulator: Simulador HDL para la simulación funcional y temporal de diseños.
o Core Generator: Generador de componentes virtuales (Intellectual Property cores).
o Schematic Viewer: Visualizador del esquemático de un diseño.
o Timing Analizer: Analizador estático de tiempos.
o FPGA Editor: Editor físico para el emplazamiento y rutado manual de un diseño.
o XPower Analyzer: Analizador estático de consumo.
o iMPACT: Permite el volcado y readback de bitstreams.
o ChipScope: Permite el análisis lógico y en tiempo real de un diseño.
o Constraints Editor: Interfaz gráfico para la edición de ligaduras de diseño e 

implementación.

 Existe una versión gratuita descargable
o Xilinx ISE Webpack: http://www.xilinx.com/support/download
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 flujo de diseño y validación (i)

Design 
Entry

Design 
Synthesis

Design 
Implementation

Behavioral 
Simulation

Funtional
Simulation

Timing
Simulation

IP cores código VHDL

informes

informes

bitstream

retardos

netlist

testbench

XESS
GXSLOAD

XESS
XUSB

XESS
XSA-3S / XST

Placa de prototipado

ligaduras

Xilinx ISE
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 flujo de diseño y validación (ii)

Design 
Entry

Design 
Synthesis

Design 
Implementation

Behavioral 
Simulation

Funtional
Simulation

Timing
Simulation

IP cores código VHDL

retardos

netlist

ligaduras

Xilinx ISE
análisis 

optimización 
secuencial

elaboración

especificación

optimización 
combinacional

proyección
tecnológica

emplazamiento
y rutado

generación
del bitstream

volcado

validación
funcional del

modelo

validación
funcional de la
implementación

validación
temporal de la 
implementación

validación del 
prototipo

bitstream

XESS
GXSLOAD

XESS
XUSB

XESS
XSA-3S / XST

Placa de prototipado
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 flujo de diseño y validación (iii)

 Las ligaduras (constraints) permiten:
o Controlar el ciclo de diseño e implementación.
o Fijar los niveles mínimos de calidad aceptables de una implementación.

 Las ligaduras pueden clasificarse según definan:
o Técnicas de diseño a aplicar (locales a módulo):

• Diseño jerárquico, codificación de FSM, estilo de RAM (block o distribuida) ...

o Estrategias de optimización (aplicables a todo el diseño):
• Objetivo de la optimización (área o velocidad), esfuerzo (normal o alto) ...

o Ligaduras físicas:
• Tiempo de ciclo, retardos, localización (celdas y pines) ...

 Las ligaduras pueden establecerse a través de:
o GUI: método simple.
o Atributos de HDL: método asociable a HDL.
o Fichero de ligaduras: método más completo.
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 flujo de diseño y validación (iv)

 Los informes (reports) son ficheros generados por las herramientas 
que contienen información sobre los procesos efectuados:
o Avisos y errores encontrados durante el proceso de diseño e implementación.
o Herramientas usadas y opciones utilizadas.
o Decisiones de diseño tomadas (inferencias).
o Estadísticas de caracterización de la implementación.

 La visualización de informes puede ser:
o Directa (fichero texto).
o A través de GUI.
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 volátil sobre FPGA

 Los bitstreams (.BIT) contienen los valores a almacenar en las 
memorias de configuración de la FPGA.
o De manera que la FPGA tenga el comportamiento especificado.

 Se vuelcan en la placa XSA‐3S a través de un puerto USB.
o Usando el adaptador a puerto paralelo XESS XSUSB y la herramienta XESS GXSLOAD.
o Esta configuración puede ir directamente a la FPGA o almacenarse en la Flash ROM.

 Diseños volcados directamente sobre FPGA: es el método habitual 
usado para el desarrollo y depuración de un diseño.
o La configuración de la FPGA reside el disco del ordenador:

• Tras cada inicialización (pulsación de PROG) o encendido de la FPGA, la configuración debe 
volcarse de nuevo.

• El CPLD toma la configuración recibida por el cable USB y la envía a la FPGA.

o Los bitstream deben tener el formato .BIT generado por Xilinx ISE.
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 permanente sobre Flash ROM

 Diseños volcados sobre Flash ROM: es el método usado para la puesta 
en producción de un diseño.
o La configuración de la FPGA reside en la Flash ROM. 

• Tras cada inicialización (pulsación de PROG) o encendido de la placa, no es necesario 
volcar de nuevo la configuración.

• El CPLD lee la configuración de la Flash ROM y la envía a la FPGA.

o En la Flash ROM dispone de 4 cuadrantes en cada uno de los cuales cabe una 
configuración (diseño) de la FPGA distinta

• Cada cuadrante es seleccionable con los interruptores SW1 y SW2 de la placa XSA‐3S.

o Antes de que un bitstream pueda cargarse en la Flash ROM el fichero en formato 
BIT debe convertirse en el formato .EXO o .MSG usando los comandos:



te
m
a 
3:

El
 e
nt
or
no

 d
e 
de

sa
rr
ol
lo
  X

ili
nx

 IS
E 
D
es
ig
n
Su

ite

11

PSyD

J.
M

. M
en

dí
as

20
15

 XESS XStools

 GXSLOAD: utilidad para el volcado de bitstreams y datos específica 
para la placa de prototipado XESS XSA‐3S.
o Pueden volcarse configuraciones en la FPGA (.BIT) y en el CPLD (.SDF).
o Pueden almacenarse configuraciones de la FPGA (.EXO o .MCS) en la Flash.
o Pueden bajarse o subirse datos de la SDRAM (.EXO, .MCS, .HEX o .XES).
o Los bitstreams / datos se arrastran y sueltan sobre la ventana correspondiente.
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 flujo de tareas

1. Crear proyecto HDL: File > New Project
o Family: Spartan3; Device: XC3S1000; Package: FT256;  Speed: 4; Language: VHDL

2. Añadir ficheros VHDL al proyecto: Project > Add Source

o El fichero se añade tanto a la vista Implementation como a la Simulation
o Alternativamente pueden crearse usando un Wizard: Project > New Source
o Usar plantillas cuando haya dudas: Edit – Language Templates

o Chequear sintáxis y salvar: Processes – Synthesize - Check Syntax

3. Añadir un fichero UCF al proyecto: Project > Add Source

o El fichero se añade a la vista Implementation

4. Implementar: Processes – Generate Programming File

5. Volcar fichero BIT (fichero de bitstream) resultante usando GXSLOAD
o Seleccionar placa y arrastrar fichero sobre la ventana FPGA/CPLD
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 flujo de tareas

 Para simulación de la especificación (no requiere implementar):

4. Añadir testbench VHDL al proyecto: Project > Add Source

o El fichero se añade a la vista Implementation

5. Simular: Processes – Simulate Behavioral Model

o Seleccionando previamente del desplegable Behavioral

 Para simulación funcional o de tiempos (tras diseñar o implementar):

5. Añadir testbench VHDL al proyecto: Project > Add Source

o El fichero se añade a la vista Implementation

6. Generar modelo VHDL deseado: Processes – Implement Design – XXX 
– Generate XXX Simulation Model

o Pueden ser tras traslación, proyección o emplazamiento

7. Simular: Processes – Simulate XXX Simulation Model

o Seleccionando previamente del desplegable correspondiente
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 La estructura de directorios de nuestro entorno de trabajo será:

 Para cada laboratorio crearemos un proyecto:
o Directorio raíz: contiene los ficheros fuente exclusivos de este  diseño, el fichero de 

ligaduras y el bitstream generado. 
o Xilinx ISE creará otros ficheros y directorios auxiliares desde dicho directorio.

 Progresivamente iremos desarrollando una biblioteca de utilidades y 
componentes reutilizables denominada common:
o Directorio raíz: contiene los ficheros fuente correspondientes. 

[DAS]

[lab2][lab1] [common]...



te
m
a 
3:

El
 e
nt
or
no

 d
e 
de

sa
rr
ol
lo
  X

ili
nx

 IS
E 
D
es
ig
n
Su

ite

15

PSyD

J.
M

. M
en

dí
as

20
15

 

 Xilinx ISE es una herramienta automática de especificación y síntesis:
o El diseñador especifica mediante VHDL el comportamiento funcional deseado.
o La implementación resultante la decide un algoritmo cuyo funcionamiento puede ser 

condicionado mediante ligaduras

 Atributos: configuran la instancia de un cierto componente primitivo
o Mediante la construcción "generic map" de VHDL

 Ligaduras de síntesis: controlan el proceso VHDL→ netlist
o Mediante la construcción "attribute" de VHDL
o A través del GUI de propiedades de síntesis (afectan al diseño completo)
o Mediante fichero ".XCF"  (debe ser incluido mediante el GUI en el proyecto)

 Ligaduras de implementación: controlan el proceso netlist → FPGA
o A través del Constraint Editor
o A través del GUI de propiedades de implementación (afectan al diseño completo)
o Mediante fichero ".UCF" (debe ser incluido en el proyecto)
o Algunas pueden aparecer en código VHDL o en el fichero ".XCF"
o No todas las ligaduras aplican a todas las familias de FPGAs
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 Relativas al proceso de síntesis – Synthesis options
o Objetivo de optimización (área o velocidad), esfuerzo en optimización...
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 Relativas a la interpretación del código – HDL options
o Algoritmo de codificación de estados, inferencia de módulos...
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 Específicas de la herramienta – Xilinx Specific Options
o Balanceo de registros, adición automática de buffers de E/S...
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 especificación (i)

 Especificación de las características de la señal de reloj:
o NET clk TMN_NET = grupoClk
o TIMESPEC TSclk = PERIOD grupoClk periodo unidad HIGH

factor_de_trabajo% INPUT_JITTER jitter unidad;

 Jitter: Desviación aleatoria máxima entre la duración de un ciclo de reloj 
cualquiera y la duración media del ciclo de reloj.

 Factor de trabajo: Fracción del tiempo de ciclo en el que la señal de reloj está en 
alta.

jitter

CLK

periodo periodo

factor
de trabajo



te
m
a 
3:

El
 e
nt
or
no

 d
e 
de

sa
rr
ol
lo
  X

ili
nx

 IS
E 
D
es
ig
n
Su

ite

20

PSyD

J.
M

. M
en

dí
as

20
15

 especificación (ii)

 Se denominan relojes derivados los que se obtienen dividiendo, 
multiplicando o desfasando un reloj maestro.

 Especificación de reloj derivado:
o NET clk2 TMN_NET = grupoClk2
o TIMESPEC TSid = PERIOD grupoClk2 TSclk [*|/] factor PHASE [+|-] 

desfase unidad;

CLK2

periodo

desfase

CLK

periodo / 2
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 especificación (iii)

 Especificación de retardo de llegada máximo a entradas: 
o [NET puerto] OFFSET = IN retardo unidad BEFORE clk RISING;

 Especificación de retardo de llegada máximo tolerable a salidas: 
o [NET puerto] OFFSET = OUT retardo unidad AFTER clk RISING;

 Especificación de retardo máximo absoluto tolerable:
o TIMESPEC TSid = FROM grupo [THRU puntos] TO grupo retardo unidad;

LCLC
Aff1 ff2B

tclk

tinput retardo

LC LC
ff3 ff4D E

toutputretardo

tclk
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 especificación (iv)

 Se denomina camino falso a todo camino de un circuito que sea 
utilizado para propagar señales inútiles. 
o No tiene que ser optimizado bajo los criterios impuestos al resto del diseño.
o Cualquier diseño con porciones de lógica compartida puede tener  caminos falsos.
o También son caminos falsos los lazos existentes en puertos bidireccionales, los 

caminos que atraviesan lógica de reset, etc.

a

+

x

b c

y

S2
y  a + c

S1
x  a + b

 Desde el punto de vista lógico en esta ruta de 
datos existen 6 caminos registro a registro:
o a  x, a y, b x, b y, c x, c y

 Sin embargo, si sobre ella sólo se realizan las 
transferencias entre registros indicadas por la 
máquina de estado, sólo algunos caminos son 
utilizados para realizar transferencias útiles:
o a x, a y, b x, c y

 Luego los restantes caminos, son caminos 
falsos que no requieren ser optimizados:
o b y, c x
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 especificación (v)

 Se denomina camino multiciclo a todo camino combinacional que 
tarda en propagar valores más de un ciclo 
o Es una técnica usada para solventar el problema de los grupos de lógica de retardo 

elevado sin reducir la frecuencia de reloj.
o Requiere que se diseñe para que el registro ubicado al final del camino no cargue 

nuevos valores en todos los ciclos.

 Identificación de caminos falsos:
o TIMESPEC TSid=FROM grupo [THRU puntos] TO grupoDest TIG;

 Identificación de caminos multiciclo:
o TIMESPEC TSid=FROM grupo TO grupo TSclk * factor;
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 especificación (vi)

 Las variaciones en la temperatura ambiente o voltaje de alimentación 
pueden alterar el retardo de un circuito. 
o Las herramientas usan en los cálculos de cualquier retardo factores de escala 

dependientes de las condiciones de funcionamiento previstas.

 Especificación de condiciones de funcionamiento:
o VOLTAGE = valor V;
o TEMPERATURE = valor C;

 Especificación de localización física de una instancia (en especial pin)
o NET instancia LOC=localizacion;

 Especificación de interfaz eléctrico de un pin
o NET instancia IOSTANDARD=interfaz;

o Donde el interfaz depende del dispositivo: LVTTL, LVCMOS33, LVCMOS25...
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 nombrado de elementos

 Muchas ligaduras requieren hacer referencia a grupos de lógica, 
existen distintas maneras de nombrarlos.
o Los nombres de las instancias se heredan de los identificadores usados en VHDL
o Para referirse a elementos concretos pueden usarse caracteres comodín (*, ?)
o Los niveles de jerarquía se  separan con /

 Agrupaciones predefinidas:
o FFS, LATCHES, RAMS, PADS, BRAMS_PORTA, BRAMS_PORTB...

 Agrupación de elementos por nombre de interconexión:
o NET interconexión TNM_NET = grupo;

 Agrupación de elementos por nombre de instancia:
o INST instancia TNM = grupo;
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 ejemplos (i)

 Indicar que la señal clk es un reloj a 50 MHz con factor de trabajo del 50% (y 
que esta ligadura afecta a todos los elementos conectados a dicha señal).

NET clk TNM_NET = clk;
TIMESPEC TSclk = PERIOD clk 20 ns HIGH 50%;

 Indicar que la señal x tiene un retraso de 5 ns respecto al flanco de subida del 
reloj de 50 MHz (20 ns de periodo):

NET x OFFSET = IN 15 ns BEFORE clk RISING;

 Indicar que la señal z requiere un margen de 5 ns respecto al flanco de subida 
del reloj de 50 MHz (20 ns de periodo):

NET z OFFSET = OUT 15 ns AFTER clk RISING;
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 ejemplos (ii)

 Indicar que la señal clk1 (12.5 MHz) se obtiene por división de la frecuencia de 
clk0 (50 MHz):

NET clk0 TNM_NET = clk0
NET clk1 TNM_NET = clk1
TIMESPEC TSclk0 = PERIOD clk0 20 ns HIGH 50%;
TIMESPEC TSclk1 = PERIOD clk1 TSclk0 * 4;

 Indicar que la señal clk1 tiene un desfase de 180º  respecto a la señal clk0 (50 
MHz):

NET clk0 TNM_NET = clk0
NET clk1 TNM_NET = clk1
TIMESPEC TSclk0 = PERIOD clk0 20 ns HIGH 50%;
TIMESPEC TSclk1 = PERIOD clk1 TSclk0 PHASE + 10 ns;
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 Indicar que los caminos que unen el regA y regB son falsos

INST regA* TNM = regA;
INST regB* TNM = regB;
TIMESPEC TSfalso = FROM regA TO regB TIG;

 Indicar que regB solo carga valores de regA en 1 de cada 2 ciclos, es decir, que 
el camino que une regA y regB es multiciclo (de 2 ciclos)

NET clk TNM_NET = clk;
TIMESPEC TSclk = PERIOD clk 20 ns HIGH 50%;
INST regA* TNM = regA;
INST regB* TNM = regB;
TIMESPEC TSmulticiclo = FROM regA TO regB TSclk * 2;
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 Indicar condiciones ambientales.

VOLTAGE = 3.3 V;
TEMPERATURE = 20 C;

 Indicar el interfaz eléctrico que se desea para el puerto x. 

NET x IOSTANDARD = LVCMOS25;

 Indicar que el puerto clk se ubique en el pin P8 de la FPGA.

NET clk LOC = P8;
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 Licencia CC (Creative Commons)
o Ofrece algunos derechos a terceras personas bajo ciertas 

condiciones. Este documento tiene establecidas las siguientes:

Más información: https://creativecommons.org/licenses/by‐nc‐sa/4.0/

Reconocimiento (Attribution): 
En cualquier explotación de la obra autorizada por la licencia
hará falta reconocer la autoría. 

No comercial (Non commercial): 
La explotación de la obra queda limitada a usos no comerciales.

Compartir igual (Share alike):
La explotación autorizada incluye la creación de obras derivadas 
siempre que mantengan la misma licencia al ser divulgadas.


